Connecting is possible again without problems at the moment. We will continue monitoring the situation.
Posted Sep 24, 2026 - 16:53 CEST
Identified
Due to a temporary increase in server load on our rsp.mbCONNECT24 (EU) S1, the server was briefly unavailable. As a result, some connections were interrupted, but they have since been successfully restored.
Our technical team will be investigating the incident and taking appropriate action to prevent further impact.
Posted Sep 24, 2026 - 15:45 CEST
This incident affected: mbCONNECT24 Servers (mbCONNECT24 Europe V2).