The issue has been identified and a fix is being implemented.
Posted Jul 09, 2026 - 13:03 CEST
Investigating
We are currently investigating reports of issues affecting login and Web2Go. Some users may experience errors or delays when trying to sign in or access Web2Go. We are actively working to identify the root cause and will provide an update as soon as more information is available.
Affected services: Login, Web2Go
Posted Jul 09, 2026 - 12:29 CEST
This incident affected: mbCONNECT24 Servers (mbCONNECT24 USA V2).